$re = '~(<SimpleData name=")NAME(">[\S\s\n]*?</SimpleData>)~m';
$str = '<SimpleData name="NAME">Angelina</SimpleData>';
$subst = "$1COUNTY$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;