use strict;
my $str = '<SimpleData name="NAME">Angelina</SimpleData>';
my $regex = qr~(<SimpleData name=")NAME(">[\S\s\n]*?</SimpleData>)~mp;
my $subst = '$1COUNTY$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";