package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<SimpleData name=")NAME(">[\S\s\n]*?</SimpleData>)`)
var str = `<SimpleData name="NAME">Angelina</SimpleData>`
var substitution = "$1COUNTY$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}