// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<SimpleData name=")NAME(">[\S\s\n]*?</SimpleData>)"#).unwrap();
let string = "<SimpleData name=\"NAME\">Angelina</SimpleData>";
let substitution = "$1COUNTY$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}