import Foundation
let pattern = #"(<SimpleData name=")NAME(">[\S\s\n]*?</SimpleData>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<SimpleData name="NAME">Angelina</SimpleData>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1COUNTY$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)