const regex = new RegExp('(<SimpleData name=")NAME(">[\\S\\s\\n]*?</SimpleData>)', 'gm')
const str = `<SimpleData name="NAME">Angelina</SimpleData>`;
const subst = `$1COUNTY$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);