re = /(<SimpleData name=")NAME(">[\S\s\n]*?<\/SimpleData>)/m
str = '<SimpleData name="NAME">Angelina</SimpleData>'
subst = '$1COUNTY$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result