using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(==.+\s(?:[\*][\s].+\s)+)";
string substitution = @"\1{{template}}\n";
string input = @"== See Also ==
* [[Link one]]
* [[more link]]
* [//external.link external link]
* [//external.link more link]
[[Category:Pages]]
[[de:Spezial Page]]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}