import Foundation
let pattern = #"(==.+\s(?:[\*][\s].+\s)+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
== See Also ==
* [[Link one]]
* [[more link]]
* [//external.link external link]
* [//external.link more link]
[[Category:Pages]]
[[de:Spezial Page]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1{{template}}\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)