import re
regex = re.compile(r"(==.+\s(?:[\*][\s].+\s)+)")
test_str = ("== See Also ==\n"
"* [[Link one]]\n"
"* [[more link]]\n"
"* [//external.link external link]\n"
"* [//external.link more link]\n\n"
"[[Category:Pages]]\n"
"[[de:Spezial Page]]")
subst = "\\1{{template}}\\n"
result = regex.sub(subst, test_str)
if result:
print(result)