use strict;
my $str = '== See Also ==
* [[Link one]]
* [[more link]]
* [//external.link external link]
* [//external.link more link]
[[Category:Pages]]
[[de:Spezial Page]]';
my $regex = qr/(==.+\s(?:[\*][\s].+\s)+)/p;
my $subst = '\\1{{template}}\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";