$re = '/(==.+\s(?:[\*][\s].+\s)+)/';
$str = '== See Also ==
* [[Link one]]
* [[more link]]
* [//external.link external link]
* [//external.link more link]
[[Category:Pages]]
[[de:Spezial Page]]';
$subst = "\1{{template}}\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;