package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(==.+\s(?:[\*][\s].+\s)+)`)
var str = `== See Also ==
* [[Link one]]
* [[more link]]
* [//external.link external link]
* [//external.link more link]
[[Category:Pages]]
[[de:Spezial Page]]`
var substitution = "\1{{template}}\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}