re = /(==.+\s(?:[\*][\s].+\s)+)/
str = '== See Also ==
* [[Link one]]
* [[more link]]
* [//external.link external link]
* [//external.link more link]
[[Category:Pages]]
[[de:Spezial Page]]'
subst = '\\1{{template}}\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result