import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(==.+\\s(?:[\\*][\\s].+\\s)+)";
final String string = "== See Also ==\n"
+ "* [[Link one]]\n"
+ "* [[more link]]\n"
+ "* [//external.link external link]\n"
+ "* [//external.link more link]\n\n"
+ "[[Category:Pages]]\n"
+ "[[de:Spezial Page]]";
final String subst = "\\1{{template}}\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}