#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[a-zA-Z0-9]\.[a-zA-Z0-9]+@example\.com$"
Local $sString = "a.test@example.com"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)