// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[a-zA-Z0-9]\.[a-zA-Z0-9]+@example\.com$").unwrap();
let string = "a.test@example.com";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}