re = /^[a-zA-Z0-9]\.[a-zA-Z0-9]+@example\.com$/
str = 'a.test@example.com'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result