import re
regex = re.compile(r"^[a-zA-Z0-9]\.[a-zA-Z0-9]+@example\.com$")
test_str = "a.test@example.com"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)