import Foundation
let pattern = #"^[a-zA-Z0-9]\.[a-zA-Z0-9]+@example\.com$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"a.test@example.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)