const regex = /^[a-zA-Z0-9]\.[a-zA-Z0-9]+@example\.com$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9]\\.[a-zA-Z0-9]+@example\\.com$', 'g')
const str = `a.test@example.com`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);