use strict;
my $str = 'a.test@example.com';
my $regex = qr/^[a-zA-Z0-9]\.[a-zA-Z0-9]+@example\.com$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";