#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(?:[^\]\[]+|\[(?:[^)(]+|\([^)(]*\])*\])*\]"
Local $sString = "1. [ "Italy" ] * 5 - [ "France","Paris" ] + 2" & @CRLF & _
"" & @CRLF & _
"2. 3*12 * ["Country"] + ["City".] * 2 + [""]" & @CRLF & _
"" & @CRLF & _
"3. [Madrid]" & @CRLF & _
"" & @CRLF & _
"4. ["Spain"] * ["Name "Industry""]" & @CRLF & _
"" & @CRLF & _
"5. "My issue" / ["Error] ["some name"]"] * 3 + 4`" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")