use strict;
my $str = '1. [ "Italy" ] * 5 - [ "France","Paris" ] + 2
2. 3*12 * ["Country"] + ["City".] * 2 + [""]
3. [Madrid]
4. ["Spain"] * ["Name "Industry""]
5. "My issue" / ["Error] ["some name"]"] * 3 + 4`
';
my $regex = qr/\[(?:[^\]\[]+|\[(?:[^)(]+|\([^)(]*\])*\])*\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}