import Foundation
let pattern = #"\[(?:[^\]\[]+|\[(?:[^)(]+|\([^)(]*\])*\])*\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. [ "Italy" ] * 5 - [ "France","Paris" ] + 2
2. 3*12 * ["Country"] + ["City".] * 2 + [""]
3. [Madrid]
4. ["Spain"] * ["Name "Industry""]
5. "My issue" / ["Error] ["some name"]"] * 3 + 4`
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)