import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?:[^\\]\\[]+|\\[(?:[^)(]+|\\([^)(]*\\])*\\])*\\]";
final String string = "1. [ \"Italy\" ] * 5 - [ \"France\",\"Paris\" ] + 2\n\n"
+ "2. 3*12 * [\"Country\"] + [\"City\".] * 2 + [\"\"]\n\n"
+ "3. [Madrid]\n\n"
+ "4. [\"Spain\"] * [\"Name \"Industry\"\"]\n\n"
+ "5. \"My issue\" / [\"Error] [\"some name\"]\"] * 3 + 4`\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}