package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(?:[^\]\[]+|\[(?:[^)(]+|\([^)(]*\])*\])*\]`)
var str = `1. [ "Italy" ] * 5 - [ "France","Paris" ] + 2
2. 3*12 * ["Country"] + ["City".] * 2 + [""]
3. [Madrid]
4. ["Spain"] * ["Name "Industry""]
5. "My issue" / ["Error] ["some name"]"] * 3 + 4\`
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}