// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(?:[^\]\[]+|\[(?:[^)(]+|\([^)(]*\])*\])*\]").unwrap();
let string = "1. [ \"Italy\" ] * 5 - [ \"France\",\"Paris\" ] + 2
2. 3*12 * [\"Country\"] + [\"City\".] * 2 + [\"\"]
3. [Madrid]
4. [\"Spain\"] * [\"Name \"Industry\"\"]
5. \"My issue\" / [\"Error] [\"some name\"]\"] * 3 + 4`
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}