$re = '/\[(?:[^\]\[]+|\[(?:[^)(]+|\([^)(]*\])*\])*\]/m';
$str = '1. [ "Italy" ] * 5 - [ "France","Paris" ] + 2
2. 3*12 * ["Country"] + ["City".] * 2 + [""]
3. [Madrid]
4. ["Spain"] * ["Name "Industry""]
5. "My issue" / ["Error] ["some name"]"] * 3 + 4`
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);