using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?:[^\]\[]+|\[(?:[^)(]+|\([^)(]*\])*\])*\]";
string input = @"1. [ ""Italy"" ] * 5 - [ ""France"",""Paris"" ] + 2
2. 3*12 * [""Country""] + [""City"".] * 2 + [""]
3. [Madrid]
4. [""Spain""] * [""Name ""Industry""]
5. ""My issue"" / [""Error] [""some name""]""] * 3 + 4`
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}