using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)[\W]((\w)[\s\xA0]*?\d+[a-z]{0,3}\/\d\d)";
string input = @"Dąbrowskiego43/45
Dąbrowskiego43/45
Kordeckiego1/11
Kordeckiego 1/11
m2/11
m2/12
p 3/12
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}