// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[\W]((\w)[\s\xA0]*?\d+[a-z]{0,3}\/\d\d)").unwrap();
let string = "DÄ…browskiego43/45
DÄ…browskiego43/45
Kordeckiego1/11
Kordeckiego 1/11
m2/11
m2/12
p 3/12
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}