use strict;
my $str = 'Dąbrowskiego43/45
Dąbrowskiego43/45
Kordeckiego1/11
Kordeckiego 1/11
m2/11
m2/12
p 3/12
';
my $regex = qr/(?i)[\W]((\w)[\s\xA0]*?\d+[a-z]{0,3}\/\d\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}