const regex = /(?i)[\W]((\w)[\s\xA0]*?\d+[a-z]{0,3}\/\d\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)[\\W]((\\w)[\\s\\xA0]*?\\d+[a-z]{0,3}\\\/\\d\\d)', 'g')
const str = `DÄ…browskiego43/45
DÄ…browskiego43/45
Kordeckiego1/11
Kordeckiego 1/11
m2/11
m2/12
p 3/12
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}