import Foundation
let pattern = #"(?i)[\W]((\w)[\s\xA0]*?\d+[a-z]{0,3}\/\d\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Dąbrowskiego43/45
Dąbrowskiego43/45
Kordeckiego1/11
Kordeckiego 1/11
m2/11
m2/12
p 3/12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)