import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)[\\W]((\\w)[\\s\\xA0]*?\\d+[a-z]{0,3}\\/\\d\\d)";
final String string = "Dąbrowskiego43/45\n"
+ "Dąbrowskiego43/45\n"
+ "Kordeckiego1/11\n"
+ "Kordeckiego 1/11\n"
+ "m2/11\n"
+ "m2/12\n"
+ "p 3/12\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}