import re
regex = re.compile(r"(?i)[\W]((\w)[\s\xA0]*?\d+[a-z]{0,3}\/\d\d)")
test_str = ("Dąbrowskiego43/45\n"
"Dąbrowskiego43/45\n"
"Kordeckiego1/11\n"
"Kordeckiego 1/11\n"
"m2/11\n"
"m2/12\n"
"p 3/12\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")