$re = '/(?i)[\W]((\w)[\s\xA0]*?\d+[a-z]{0,3}\/\d\d)/';
$str = 'Dąbrowskiego43/45
Dąbrowskiego43/45
Kordeckiego1/11
Kordeckiego 1/11
m2/11
m2/12
p 3/12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);