re = /(?i)[\W]((\w)[\s\xA0]*?\d+[a-z]{0,3}\/\d\d)/
str = 'DÄ…browskiego43/45
DÄ…browskiego43/45
Kordeckiego1/11
Kordeckiego 1/11
m2/11
m2/12
p 3/12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end