import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":value=(\".*)@input=(\".*?\")";
final String string = "<VSection :value=\"...\" key=keyid @input=\"...\" title=\"Infer an AI Model\">\n";
final String subst = ":model-value=$1@update:model-value=$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}