use strict;
my $str = '<VSection :value="..." key=keyid @input="..." title="Infer an AI Model">
';
my $regex = qr/:value=(".*)@input=(".*?")/mp;
my $subst = ':model-value=$1@update:model-value=$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";