$re = '/:value=(".*)@input=(".*?")/m';
$str = '<VSection :value="..." key=keyid @input="..." title="Infer an AI Model">
';
$subst = ":model-value=$1@update:model-value=$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;