re = /:value=(".*)@input=(".*?")/m
str = '<VSection :value="..." key=keyid @input="..." title="Infer an AI Model">
'
subst = ':model-value=$1@update:model-value=$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result