// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m):value=(".*)@input=(".*?")"#).unwrap();
let string = "<VSection :value=\"...\" key=keyid @input=\"...\" title=\"Infer an AI Model\">
";
let substitution = ":model-value=$1@update:model-value=$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}