#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bfrom \w+ in (\w+)\nprevious in time\b"
Local $sString = "from ab1c_table in WXY" & @CRLF & _
"previous in time" & @CRLF & _
"" & @CRLF & _
"from abc3_table in MNO" & @CRLF & _
"previous in time" & @CRLF & _
""
Local $sSubst = "<font color="#FF4500"><b>$0</b></font>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)