import Foundation
let pattern = #"\bfrom \w+ in (\w+)\nprevious in time\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
from ab1c_table in WXY
previous in time
from abc3_table in MNO
previous in time
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"<font color="#FF4500"><b>$0</b></font>"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)