import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfrom \\w+ in (\\w+)\\nprevious in time\\b";
final String string = "from ab1c_table in WXY\n"
+ "previous in time\n\n"
+ "from abc3_table in MNO\n"
+ "previous in time\n";
final String subst = "<font color=\"#FF4500\"><b>$0</b></font>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}