using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bfrom \w+ in (\w+)\nprevious in time\b";
string substitution = @"<font color=""#FF4500""><b>$0</b></font>";
string input = @"from ab1c_table in WXY
previous in time
from abc3_table in MNO
previous in time
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}