// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bfrom \w+ in (\w+)\nprevious in time\b").unwrap();
let string = "from ab1c_table in WXY
previous in time
from abc3_table in MNO
previous in time
";
let substitution = "<font color=\"#FF4500\"><b>$0</b></font>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}