re = /\bfrom \w+ in (\w+)\nprevious in time\b/m
str = 'from ab1c_table in WXY
previous in time
from abc3_table in MNO
previous in time
'
subst = '<font color="#FF4500"><b>$0</b></font>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result